About

This library provides bindings to Oniguruma, a regular expression library which is standard with Ruby 1.9. It allows users of Ruby 1.8 to access the extended functionality without the need to recompile or to upgrade Ruby.

This site provides an overview of the library, the api documentation is here.

Requirements

  • Oniguruma regular expression library (>= 4.x.x)

Installation

If you have rubygems installation is straightforward by typing (as root if needed):

gem install -r oniguruma

If you prefer to get the sources, the last stable version may be downloaded here.

Status

The library interface is mature. Existing bugs are being fixed as they are found.